Welcome, Guest. Please login or register.
November 13, 2019, 03:07:33 am

Login with username, password and session length
Director PLEASE!!!!
Add your location information to your personal profile. Thanx!
435293 Posts in 37285 Topics by 9537 Members
Latest Member: Mgabski
Search: Advanced search
Advertiser Inquiries
+ My Community
|-+ General Tech
| |-+ Forced Induction
| | |-+ Turbos
| | | |-+ exhaust fumes inside car with on3 set up
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: exhaust fumes inside car with on3 set up  (Read 4654 times)
sprayed347
Small Block
***
Offline Offline

Posts: 190

Location: stl

« on: February 12, 2016, 11:47:46 am »

 have your typical foxbody,306 fcam 1.7s,perf.rpm heads,cobra int.42lb inj. on3 70mm turbo kit.there y pipe to a mac cat back system with tail pipes.I had a lot of leak issues at the downpipe to turbo connection and all the vbands.Took it apart put copper hi temp rtv on all flanges,reclamped everything.let it sit overnight.It is 3 times better now but still stinks in the car enough that after driving with the windows half way down you still need to change clothes and shower...I don't see any cracks in the headers or any leaks at header to head.Iam also using copper rtv instead of header gaskets.Anybody else have these issues?how did you cure them?I built this set up for my wife and she loves the car but not the smell...
Logged

it aint braggin motherfucker if ya back it up
rob342
Adv_SBFTechie
Stroked Small Block
****
Offline Offline

Posts: 388


Location: darien, il

« Reply #1 on: February 12, 2016, 01:58:52 pm »

New weather strip all around and a tailpipe that runs all the way back. I'd bet you are missing one of both of those
Logged

white 92GT, with a black interior, pony rims, 5 speed with a 3.73 gear. came with a gear, exhaust, and a powerdyne. nice little cruiser, i didn't change much yet.

have tw170's, systemax II, 75mm accufab, anderson n41, t5z, ford racing 23lb billet flywheel, and a quarterhorse sitting here. cam may change
sprayed347
Small Block
***
Offline Offline

Posts: 190

Location: stl

« Reply #2 on: February 14, 2016, 07:44:50 pm »

nope those were the first things i did along with sealing up the shifter boot area.
Logged

it aint braggin motherfucker if ya back it up
rob342
Adv_SBFTechie
Stroked Small Block
****
Offline Offline

Posts: 388


Location: darien, il

« Reply #3 on: February 15, 2016, 01:08:58 pm »

is it a GT? i only ask as i have had open long tube and dumped muffler setups and without the ground effects i never had a stink issue. i have been chasing this issue with my DD GT as well. it's fine with the windows up.  my car has no turbo/no leaks.

i'm actually leaning towards getting a cobra bumper to help get the fumes out from under the car easier and adding some high flow cats. 

in my case it stinks more driving than idling so i'm convinced the air is tumbling around behind the car and finding it's way in. like with the windows down it creates a vacuum at speed that sucks fumes in the back somewhere. tightening my hatch helped. replacing the door seals helped, patching the screw holes in the hatch area helped. next up for me will be replacing the tailight housing to body gaskets.  are you sure it's still an exhaust leak? can you rent or borrow a smoke machine?
Logged

white 92GT, with a black interior, pony rims, 5 speed with a 3.73 gear. came with a gear, exhaust, and a powerdyne. nice little cruiser, i didn't change much yet.

have tw170's, systemax II, 75mm accufab, anderson n41, t5z, ford racing 23lb billet flywheel, and a quarterhorse sitting here. cam may change
sprayed347
Small Block
***
Offline Offline

Posts: 190

Location: stl

« Reply #4 on: February 24, 2016, 09:31:19 am »

I pressurized the system with my shop vacc. sprayed the system down with soapy water..every joint was leaking...including the turbo mounting.only thing that was not was the headed flange were I used rtv.got new v band clamps,cleaned and filed all surfaces.found flange on turbo pitted and slightly warped. filed it smooth and used hi temp rtv on every v band and turbo mounting let sit over night retest only have a slight leak at ball and socket flange at crossover pipe.road test 95%fixed now only get it from wastegate when under boost.
Logged

it aint braggin motherfucker if ya back it up
Pages: [1] Go Up Print 
« previous next »
Jump to:  



Powered by MySQL Powered by PHP Valid XHTML 1.0! Valid CSS!
Powered by SMF 1.1.21 | SMF © 2015, Simple Machines



408 Stroker