SBFTECH.com Experienced Small Block Ford Tech

Small Block Talk => 351W Small Blocks => Topic started by: elliott000 on January 06, 2018, 12:17:03 am



Title: something has changed. lean condition under acceleration
Post by: elliott000 on January 06, 2018, 12:17:03 am
Hey guys,  For quite some time my truck has been running great. carbed 351w with a truck avenger 670. I have an afr gauge in there and that was a great help for tuning. Lately though something has changed, I have developed a lean condition under acceleration and it stays that way until about 3000 rpm(assume secondaries come in) or when the power valve opens(seen via vac gauge beside afr)

I have changed nothing on the carb when this started happening. The fuel filter was done a few months ago when i put in a new fuel pump. Fuel supply is good and my bowls are set a bit lower than the sight hole.... helps offroad

Any thoughts on it, am I correct in assuming its only something to do with the primary circuit?

Should I pull the carb and give it a soak in cleaner overnight and then re try?

thanks for any help, cant wheel and its the best time of year for it..... maybe time for an injection kit haha


Title: Re: something has changed. lean condition under acceleration
Post by: juiced coupe on January 06, 2018, 06:42:08 am
Avenger series carbs are known for being lean under acceleration.

It could also be different fuel that is made for different times of the year.

But giving it a good cleaning wouldn't be a bad idea.


Title: Re: something has changed. lean condition under acceleration
Post by: quickshift on January 06, 2018, 07:29:00 pm


It could also be different fuel that is made for different times of the year.


If no other changes were made, this is your answer.


Title: Re: something has changed. lean condition under acceleration
Post by: elliott000 on January 07, 2018, 06:09:29 pm
Good to know, ill try some different gas but in the yrs of driving it. This has never happened so it seems odd. Especially since it's not just like 13.5/15 lean but pins over to 18. Ill drain the tank and add fresh fuel but I'm also going to blow the carb thru n thru


Title: Re: something has changed. lean condition under acceleration
Post by: 85_GT on January 08, 2018, 02:05:18 pm
Somethings to look at:
Gaskets get old and can leak.  Bolts come loose. Snug the intake bolts, same for carb.
AFR wideband sensors wear out.


Title: Re: something has changed. lean condition under acceleration
Post by: elliott000 on January 08, 2018, 02:19:54 pm
I have some good and bad news haha. I believe I found the issue, I took the carb off and tore into it. All passages seem good and clean but I ran carb cleaner and air through anyway. I pulled the squirter and there was a filing sitting on the edge of the needle and the threaded bore of the hole its in. I believe this may have been jammed or restricting flow out of the accelerate pump circuit which has would definitely tie into the lean at acceleration. BUT my squirter thread said are shot and stripped out. Wtf now


Title: Re: something has changed. lean condition under acceleration
Post by: juiced coupe on January 08, 2018, 03:29:14 pm
http://blp.com/cart/index.php?main_page=product_info&cPath=78_206&products_id=954


Title: Re: something has changed. lean condition under acceleration
Post by: quickshift on January 08, 2018, 04:08:30 pm
http://blp.com/cart/index.php?main_page=product_info&cPath=78_206&products_id=954
Nice find Juiced. In the past, I would use a 1/2" drill bit to shorten the shooter from the top to gain more thread for the screw to engage ...talk about red neck... : :naughty:


Title: Re: something has changed. lean condition under acceleration
Post by: elliott000 on January 08, 2018, 08:34:56 pm
Quickshift I like that idea for a quick fix haha. Well I put it all back together and it's better but far from perfect. The wideband is good because even if it was pooched u can feel the falling off when driving. Im gunna drain all the gas to o2 and put 5 gallons of different gas in there and try. Stuff in three now is Chevron, ill try some shell


Title: Re: something has changed. lean condition under acceleration
Post by: quickshift on January 08, 2018, 08:44:14 pm
Where are you located?  Air temp has a lot to do with tuning,especially if your on the edge with jetting.


Title: Re: something has changed. lean condition under acceleration
Post by: elliott000 on January 09, 2018, 01:31:22 am
I'm in Vancouver bc. It's 6 Celsius these days. I've had the ol bugger out in - 2c snow wheeling a few weeks back before this started. That's what stumps me is the no change. Could an internal engine issue show up like this? Leaky valves or something. It'd be nice if I could find a carb to bolt on for a laugh and see what it says